syslog-receive
Syslog is a standard for message logging. A syslog server (a "collector") gathers log messages coming from syslog clients ("originators").
syslog-receive is a command-line (shell) utility that works as a syslog server.
Features
- IPv4 and IPv6
- BSD syslog protocol (RFC3164)
- IETF syslog protocol (RFC5424)
- Syslog over UDP (RFC5426)
- Syslog over TCP (RFC6587)
- Syslog over TLS (RFC5425)
- Limit for maximum message size
- 'Non-transparent-framing' message format
- 'Octet-counting' message format
- TLS: Optional request of clients certificates
- TLS: Certification path validation
- TLS: Certificate fingerprints validation
- UTF-8 and custom charsets
- Optional hexadecimal output
Downloads
- Windows 64-bit: syslog-receive-0.9.0-win64.zip (1,550,322 bytes),
- Windows 32-bit: syslog-receive-0.9.0-win32.zip (1,240,938 bytes),
Documentation
License
In simple words: syslog-receive is free to use. For full details refer the End-User License Agreement.
Contact us for a special license if you want to include syslog-receive as a part of your commercial product.